Why no log output after connecting the debug port?

Description

After connecting the debug port and booting up my SBC, I cannot receive any log output.

SoC

JH7100

SBC

VisionFive

Software

N/A

Cause

Customer faulty operation.

The customer mistook the debug port for burning firmware as the serial port for debug purposes.

Solution

Make sure you have used the correct pins and followed the correct procedures.

Procedure

The SBC has 2 serial pins, one for regular use and the other for debug purposes.

For regular use: If you need to perform regular tasks, for example, to view log files on your SBC, or to update firmware and u-boot, follow the procedures as described in Appendix B: Updating Firmware and u-boot of the VisionFive Single Board Computer Quick Start Guide.

Result: Your SBC will display log information during system boot-up.

For debug purposes: If you need to flash firmware (for example, to flash files like jh7100_recovery_boot, bootloader, and ddrinit to an SBC), follow the procedure as described in Appendix C: Recovering the Bootloader of the VisionFive Single Board Computer Quick Start Guide.
Note: If you mistake this pin as the one for normal use, you cannot receive any log information during boot-up.
Note: For SBC used for debugging, its SPI flash must be blank.